编辑器功能概述

在线编辑器功能概述：

所见即所得的在线编辑器。顾名思义，就是能在网络上使用所见即所得的编辑方式进行编辑图文并茂的文章、新闻、讨论贴、通告、记事等多种文字处理应用。其主要特点如下：

  • 所见即所得
    即通过编辑器编辑的文字、图片等HTML标记输出到页面的效果和编辑时显示的效果一致，让使用者方便地对编辑的内容进行修改、排版等。
  • 自动转换为HTML代码
    在编辑状态编辑的文字、图片等内容都在后台自动转换为可被浏览器识别的HTML标记语言，使用者更能在代码状态在对代码标记进行修改。
  • 简单易用
    编辑器的编辑及使用方法与FrontPage、Dreamweaver等著名主页制作软件类似。无需任何HTML语法知识、儍瓜式的操作让即使没有主页制作经验的使用者也能快速上手。
  • 方便快捷
    使用所见即所得的编辑器能快捷、方便地编辑出效果一流的图文效果，如果使用纯手工编写代码的方法编辑则需要浪费大量时间及精力。


编辑器界面概述

在线编辑器界面概述：

所见即所得的在线编辑器界面主要分为以下三大部分：

  • 工具栏
    编辑器顶部为工具栏，主要放置各种编辑功能的选项及按钮图标，使用者只需点击图标或选择相关选项即可实时对编辑栏编辑的内容进行添加或修改、修饰。
  • 编辑栏
    编辑器中部空白处为编辑栏，主要是供使用者输入及编辑内容所用，同时所编辑的内容全部都是所见即所得，但有部分内容，如活动的图像、文字、电影等在编辑状态下只会呈现静止状态，需使用者转换到预览状态方可真实再现。
  • 状态栏
    编辑器底部为状态栏，主要放置转换编辑器状态的按钮图标，状态共分为：代码状态、编辑状态（默认）、预览状态。具体每种状态的作用请详见帮助中心目录的“状态栏使用说明”。


编辑器使用技巧

编辑器使用技巧一览：

  • 乾坤小挪移
    如果在网络上看到哪篇文章或新闻甚至页面觉得不错的话，可以用鼠标将相应页面内容全部选择起来后，直接拖动或复制到编辑器的编辑框即可，而且原页面上的图片、文字、CSS样式、动态效果等都能原封不动地转移到编辑框，不用修改或添加任何代码。
  • 巧用插入自动播放媒体功能
    插入自动播放媒体功能可以自动识别各种媒体格式并用相应的播放器在页面自动播放，而且这个功能还能识别图像文件，压缩文件等。大家可以充分利用此功能编辑出更多色声俱全的内容。
  • 灵活运用预览状态
    编辑内容中带有动态效果、即时播放媒体、GIF动画等活动内容时，编辑状态中只能显示静态的图像或播放器界面，这时只需要将状态转换为预览状态就可以马上看到这些内容的动态实时效果，如果想继续编辑的话，只需再转换到编辑状态即可。


编辑器疑难解答

在线编辑器疑难解答：

Q：我不会任何HTML语法及没有任何主页制作经验，能用好这个编辑器吗？

A：绝对没有任何问题，因为编辑器是完全所见即所得的，所以HTML语法都在后台自动生成。至于使用方面，本编辑器也尽量做到简单易用，相信您能在短时间内学会使用这个功能强大的编辑器的。

Q：与普通文本输入框相比，HTML编辑器有什么优势之处？

A：最大的优势就是让使用者更方便快捷地编写出各种不同样式及效果的HTML内容，以往普通文本输入框要实现这些HTML效果的内容就需要使用者具备一定的HTML语法或UBB语法，而且编写内容的时候是手工编写代码方式的，除了不直观以外，还经常出现编写好内容并输出后才发现效果不理想等情况。而使用HTML编辑器则完全杜绝了这些情况的发生。

Q：为什么我无法使用编辑器的部分或全部功能？

A：因为编辑器使用了JAVASCRIPT客户端语言，如果浏览器不支持JAVASCRIPT或关闭了这个功能的话，编辑器就不能正常工作了。另外，编辑器还需要使用者的浏览器版本是IE5.0以上，否则编辑器同样不能正常工作。


编辑器编辑栏

编辑器编辑栏(下图红框处)主要放置供使用者编辑内容的编辑框，若内容超出框架宽度或长度的话，会自动出现滚动条。另外还可通过状态栏的状态转换可转换编辑框的不同编辑状态。


编辑器状态栏说明

在线编辑器状态栏使用说明：

编辑器状态栏放置有编辑器状态转换栏，共有两种状态可供转换（如下图），详细如下：

：代码状态，在此状态下所有编辑的内容皆以HTML标记源代码方式显示或编辑。 在代码区里，所有的工具将无效，如需查找代码，可按快捷键是ctrl+F “全选”快捷键是ctrl+A “删除”键是delete

：设计状态(默认)，在此状态下所有编辑的内容皆为所见即所得的方式。


第一排工具栏：

下面分别介绍各个按扭：

段落样式：一共有8种段落样式，默认为普通。标题一的字体最大，标题六的字体最小。而且，选中标题一至标题六都会把字体变粗。

字体：选中要编辑的文字，然后单击此按钮，即可改变字体。IE默认能浏览的字体只有这13种，当然您还可以自定义一些特殊字体，比如舒体。但网民的电脑上一定要安装了这种特殊字体才能查看这些内容，如果不装就会看不到。因为不确定所以我们不建议您使用特殊字体。如果一定要用特殊字体，就把字做成图片，再插入到网页编辑器里。这样就能确保所有的网民都能看到了。

字号：选中要编辑的文字，然后选一种字号即可改变大小。1号为最大，7号最小。锐奇的模板都已经用样式表来控制字号大小了。所以您在网页编辑器里编辑文字时，尽量不要再改变字体的大小。如果改变了，很可能会出现有的网民机子上看到的字体大，有的机子上看到的字体小这种情况。因为IE浏览器可调整字体大小的，点击“查看/字体大小”即可改变。

百分比选择：此按钮可调整整个编辑区内容的显示大小，数值为100%时是正常状态，数值小于100%时为缩小状态，比例越小，编辑区内可看的内容越多。数值大于100%时为放大状态，比例越大，编辑区内可看的内容越少。此按钮的作用主要是为了让制作者更方便地查看整个网页的排版样式，方便设计。

粗体：选中文字，按一次此按钮，会将文字变成粗体字。再按一次此按钮，就会撤消此次操作。

斜体：选中文字，按一次此按钮，会将文字倾斜。再按一次此按钮，就会撤消此次操作。

下划线：选中文字，按一次此按钮，会给文字加一条下划线。再按一次此按钮，就会撤消此次操作。

中划线：选中文字，按一下此按钮，就会给文字增加一条删除线。再按一次此按钮，就会撤消此次操作。

上标：选中文字，按一下此按钮，就会将文字做成上标。再按一次此按钮，就会撤消此次操作。

下标：选中文字，按一下此按钮，就会将文字做成下标。再按一次此按钮，就会撤消此次操作。


第二排工具栏：

下面分别介绍各个按钮：

剪切：选中要剪切的字体或者图片，然后单击此按钮即可。或者是同时按住键盘上的　ctrl + x 键。

复制 ：选中要复制的字体或者图片，然后单击此按钮即可。或者是同时按住键盘上的 ctrl + c 键。

常规粘贴：将刚才复制或者剪切的内容（比如文字和图片），全部粘贴到网页编辑器。方法是将光标定位在目标处，然后单击此按钮即可。或者是同时按住键盘上的　ctrl + v　键。

纯文本粘贴：假设刚才复制了图片和文字，但只想粘贴文字，就按此按钮。

从WORD粘贴：如果要粘贴从WORD里拷贝的内容，就必须单击此按钮，这样可以清除WORD生成的垃圾代码，让网页能正常显示。

查找替换：单击此按钮，在弹出的对话框里（如下图1）输入“查询内容”单击“查找下一个”即可查找内容。如需替换，在“替换内容”栏输入内容，单击“替换”按钮，即可单个替换。如需一次性完成全部替换，就单击“全部替换”按钮。

(图1)

删除：选中要删除的字体或者图片，然后单击此按钮即可，或者键盘上的“Delete”键。

删除文字格式：选中文字，单击此按钮，即可删除所有的文字格式，比如“粗体，斜体”等格式。

撤消：刚刚录入的资料，如果不想要了，就单击此按钮即可撤消。

恢复： 单击此按钮即可恢复刚刚撤消的内容。

全部选中：单击此按钮，可选中整个编辑器里的内容。或者是同时按住键盘上的　ctrl + A 键

取消选择：取消选中的内容

编号：添加数字编号。方法是将光标放在需要添加编号的位置，单击此按钮即可添加。再把光标放在行尾，按回车键，即可自动产生下一个编号。

项目符号：添加实心黑点。方法跟“编号”类似。将光标放在需要添加黑点的位置，单击此按钮即可添加。再把光标放在行尾，按回车键，即可自动产生下一个编号。

增加缩进量：通常一段文字的第一行，要缩两个空格，这个按钮就是方便此操作的。 减少缩进量：与“增加缩进量”相反。

段落属性：调整整段文字的显示方式。方法是，选中整段文字，单击此按钮，在弹出的对话框里填入具体的数字，即得到相应的改变。

其中：“空白”项表示可在“段前、段后、文本之前、文本之后”增加一些空白区域。

其它：可设置整段文字的对齐方式、行距大小（行与行之间的距离）、首行缩进（第一行文字缩进空白区域）、单字间距（字与字之间的距离）

文字颜色：选中要修改颜色的字体，然后单击此按钮，选择您需要的颜色，按“确定”即可。

对象背景颜色：把光标放在需要增加或者修改背景色的表格或者单元格里，然后单击此按钮，选择颜色，按“确定”即可。

字体背景颜色：选中要改背景颜色的字体，然后单击此按钮，选择您需要的颜色，按“确定”即可。

背景图片：把光标放在需要增加或者修改背景图片的表格或者单元格里,单击此按钮，在弹出的对话框里(如图2)，选择一张图片，插入即可。

(图2)

其中：
"图片来源"有三种：
上传：选择上传，可以从电脑里选一张背景图（小于2M），按确定即可
网络：输入一张图片的网址，按确定即可（注意：上传到网站管理后台中我的文档的图片，点击旁边的“浏览”按钮，都可以查看该图片的网址）
系统：选择系统自带的一张图片，按确定即可。

"平铺方式"有四种：
纵向横向：不断地复制这张背景图，直至将整个表格或者单元格铺满。
不平铺：只插入一次背景图。图片是多大的，整个背景就多大。
纵向：从上至下复制这张背景图片
横向：从左至右复制背景图片,即只在一行里显示背景图，不能将背景图复制到下一行


表格菜单

表格菜单：包括插入表格、表格属性、单元格属性、拆分单元格等等15个表格功能(如图1)，

图1

在编辑器的第四排工具栏里(如图2)，也有这些表格功能的按钮。您根据自己的习惯，随便选一处使用就可以。下面详细介绍每个表格功能的用法:

(图2)

插入表格：单击此按钮，即可弹出以下对话框(如下图3)，输入表格行数，列数，设置边框粗细等等属性之后，按“确定”按钮，即可插入一个表格。

注意：如果您把光标放在表格外，再单击“表格菜单”，那么只有“插入表格”项是可用的，其它项都是灰色状态，代表不可用。
如果您把光标放在表格里或者单元格里，再单击“表格菜单”，那么所有选项都是可用的。

表格属性：把光标放在表格里，再选择“表格属性”也会弹出一个属性对话框（如下图3）

(图3)

详细介绍如下：“表格大小”:行数和列数都默认为2，修改数值即可改变行数列数

“表格布局”:
对齐方式(在页面中摆放表格的位置，可以选择右对齐，左对齐，水平居中，两端对齐。默认情况是靠左对齐，但这要视表格大小来决定)
边框粗细(默认为1，数值越大，边框线越粗，当边框设为0时，表格是隐形的)
单元间距(在一个表格中，单元格与单元格之间的距离称为单元格格间距，默认为2)
单元边距(在一个表格中的一个单元格中，表格边距与该单元格中的正文之间的距离称为单元格格边距，默认为2)

如下图：

(图4)

“表格尺寸”:
指定表格高度(设置表格的高度。如果你没有指定高度的值，那么表格将根据表格中的对象自调整。)
指定表格宽度(表示表格大小的单位有两种：百分比和像素。默认为百分比，一般来说，我们也建议您选择百分比，因为它可以根据访问者显示器大小和浏览器窗口大小自行调整，灵活性较高。而且用百分比来表示表格的宽度之后，就不会出现由于表格太宽而把网站三区挤窄或者把整个网页挤变形的情况了。)

“表格样式”:
边框颜色(设置表格边框的颜色。如果您取消了边框，那么边框颜色设置将无效)
边框样式(设置表格边框的样式。如果您取消了边框，那么边框样式设置将无效)
背景颜色(设置整个表格的背景颜色。您可以在弹出的颜色板选择自己满意的颜色，按确定即可)
背景图片(如果您想将图片作为背景，那么单击图标，在弹出的对话框里选择一张背景图片，按确定即可。方法与“插入或者修改图片”按钮相同。注意：设置好背景图片后，背景颜色设置将无效；

注意：如果想取消背景图，就将光标放在表格里，选择“表格属性”，再单击背景图片旁边的图标，将“取消背景图”前的圆点选上即可，如下图5

(图5)

单元格属性：把光标放在某个单元格内，再单击此按钮，在弹出的对话框里（如下图6），进行相关设置，按“确定”即可修改单元格的属性。

(图6)

注意：一次只能修改一个单元格，详细介绍如下：

“布局”：
水平对齐（该项设置决定了单元格格内文本或者图片的水平（即左右）对齐方式。可以选择右对齐，左对齐，水平居中，两端对齐）
垂直对齐（该项设置决定了单元格格内文本或者图片的垂直（即上下）对齐方式。可以选择顶部、中部、基线、底部。默认是居中对齐）

“尺寸”：
指定高度(设置单元格的高度。如果你没有指定高度的值，那么单元格将根据单元格中的对象自调整。)
指定宽度(表示单元格大小的单位有两种：百分比和像素。默认为百分比，我们也建议您选择百分比作单元格大小的单位)

“样式”：（单元格的样式设置方法与表格的相同）

备注：表格是由一个个的单元格构成的。如2行3列的表格，就由6个单元格构成。3行3列的表格就由9个单元格构成。表格的行数*列数=单元格总个数。

当您插入一个表格后，您可以利用以下工具很方便的调整表格，比如合并单元格格，删除单元格格，合并行，合并列等等。

拆分单元格：点选某一个单元格，选择此按钮,这时弹出“拆分单元格”设置框(如图7)，选择拆分列或者行，然后输入列和行数，单击确定按钮即可。

(图7)

表格行属性：修改整行单元格的属性(比如一行里有4个单元格，那么此次修改会在4个单元格里生效)，属性面板上的功能跟单元格属性的相同。

插入行（在上方):点击表格中的某一行，再单击此按钮，即可在表格上方插入一行。
插入行（在下方）：在表格下方插入一行。
合并行（向下方）：点击表格中的某一行，再单击此按钮，即可将这行表格与下面一行表格合并在一起。
拆分行：点击表格中的某一行，再单击此按钮，即可将这行表格拆分成两行。如果想拆分成多行，请选择“拆分单元格”按钮。
删除行：点击表格中的某一行,再单击此按钮，可删除一行表格。
插入列（在左侧）：点击表格中的某一列，再单击此按钮,即可在单元格的左侧，插入一列单元格。
插入列（在右侧）：点击表格中的某一列，再单击此按钮,即可在单元格的右侧，插入一列单元格。
合并列（向右侧）：点击表格中的某一列，再单击此按钮,即可将这列单元格与右边一列单元格合并在一起。
拆分列：点击表格中的某一列，再按一下此按钮，即可将单元格再拆分出一列。
删除列：点击表格中的某一列，再按一下此按钮，即可删除此列。


插入或者修改图片

插入或者修改图片（即格式为gif或者jpg的文件）：将光标定位在需要插入图片的位置，单击此按钮，在弹出的对话框里(如下图)，选择一种上传方式，上传好图片后单击“确定”按钮即可。

其中：
"图片来源"有两种：
上传：选择“上传”，单击“浏览”按钮，从电脑里选一张图片（小于2M），按确定即可
网络：选择“网络”，单击“浏览”按钮，从列表里选中一张图片，按确定即可（在后台“我的文档”里上传的图片，都会显示在此列表里）

"显示效果"属性有9个，分别是：
说明文字：给图片加上说明，效果是预览网站时，鼠标移至图片上方，会显示文字说明内容。
边框粗细：默认为0，即图片是没有边框线的。数值越大，图片的边框线越粗
边框颜色：设置图片的边框颜色
特殊效果：给图片加特殊效果，比如：半透明，阴影，发光等。您可以分别选中这些效果，然后预览网站看看。
对齐方式：一共有9种图片对齐方式，分别是：左对齐、右对齐、顶部、中部、底部、绝对居中、绝对底部、基线、文本顶部。使用方法：把光标放在需要插入图片的文字旁边，再插入图片，选择一种对齐方式，即可看到效果。

图片宽度：设定图片的宽度，即长度。数值越大，图片越宽。
图片高度：设定图片的高度，数值越大，图片越高。
上下间距：图片与上下两行的对象（比如文字、图片、表格）的距离；数值越大，间距越大；反之越小。
左右间距：图片与左右两边的对象（比如文字、图片）的距离；数值越大，间距越大；反之越小。

注意：插入图片后，如果要修改图片的属性，可直接右击图片，选择“图片属性”即可做相应的修改。如下图：


插入FLASH动画

插入FLASH动画：（即格式为swf的文件）
将光标定位在需要插入FLASH的位置，单击此按钮，在弹出的对话框里（如下图），选择一种上传方式，上传好FLASH后单击“确定”按钮即可。

其中：
"图片来源"有两种：
上传：选择“上传”，单击“浏览”按钮，从电脑里选一个FLASH（小于2M），按确定即可
网络：选择“网络”，单击“浏览”按钮，从列表里选中一个FLASH，按确定即可（在后台“我的文档”里上传的FLASH，都会显示在此列表里）

“显示效果”
显示宽度：可定义FLASH的宽度，数值越大，FLASH越宽；反之FLASH越窄
显示高度：可定义FLASH的高度，数值越大，FLASH越高；反之FLASH越短
获取长度：1、如果FLASH是从“网络”项选择的，单击此按钮后，会得到FLASH的正确尺寸。这就解决了旧版编辑器里，插入FLASH后，FLASH变小的问题了。
2、如果FLASH是从“上传”项选择的，单击此按钮将无效。因为程序只能获取已经上传到网络里的FLASH长度,所以建议客户先把FLASH上传到“我的文档”然后再选择用“网络”项插入FLASH。
透明:将“透明”二字前的方框打上勾，即可将FLASH的背景设为透明的显示在网页上。比如在一张图片上插入透明FLASH时，就用到此功能。


插入其它文件

插入其它文件：除了图片和媒体文件外，其它的文件就用此按钮上传到网页上。比如是word文件，网民预览网站时，如果他电脑里没装word软件，那么点一下这个文件名即可下载该文件。如果装了word软件，那点一下这个文件名就可以浏览该文件了。

使用方法是：把光标放在需要插入其它文件的位置，单击此按钮，在弹出的对话框里（如下图），选择一个文件上传即可。

文件来源有两种，分别是：
上传：选择“上传”，单击“浏览”按钮，从电脑里选一个其它格式的文件（比如压缩文件、word文件等），按确定即可
网络：选择“网络”，单击“浏览”按钮，从列表里选中一个文件，按确定即可（在后台“我的文档”里上传的FLASH，都会显示在此列表里）

---------------------------------------------------------------------------

远程自动上传：当复制别人网站图片的时候,点此按钮，会自动将别人网页里的图片上传到自己的服务器里，变成自己的图片。因为别人网站上的图片是存放在别人的服务器上的，别人想删就删了，所以一定要变成自己的图片，这样您才有自主权。
使用方法：先从别人的网站上，将网页内容复制到编辑器里，然后单击此按钮。稍等片刻，图片即可自动上传。

注意：您单击此按钮后，如果长时间(比如十几分钟甚至几十分钟)一直显示“远程文件收集中，请稍候”，那可能是网速太慢了所以无响应。您应该退出编辑器，重新复制网页重新单击此按钮，再试一遍。


插入自动播放媒体

插入自动播放媒体：只要是Windows Media Player播放器和realone播放器支持的格式文件，都能插入到网页里。

注意：网民的电脑一般已默认安装Windows Media Player播放器，但不一定会装RealOne播放器，所以建议您插入Windows Media Player支持的格式文件，最好是*.wma格式。

Windows Media Player播放器支持以下格式的文件：*.mid,*.rmi,*.midi,*.mov,*.qt,*.asf,*.wm,*.mpeg,*.mpg,
*.asx,*.wax,*.m3u,*.avi,*.wmv,*.wav,*.snd,*.au,*.aif格式。

RealOne播放器支持以下格式的文件：*.rm格式

使用方法是：将光标放在需要插入媒体文件的位置，单击此按钮，在弹出的对话框里（如下图）上传一个文件，设好播放器的宽度和高度，按“确定”即可。

此按钮的属性有两项：

媒体文件来源：
上传：选择“上传”，单击“浏览”按钮，从电脑里选一个媒体文件（小于2M），按确定即可
网络：选择“网络”，单击“浏览”按钮，从列表里选中一个媒体文件，按确定即可（在后台“我的文档”里上传的FLASH，都会显示在此列表里）

播放效果：
播放宽度:指播放器的宽度，数值越小，播放器越小；反之越大。
播放高度:指播放器的高度，数值越小，播放器越小；反之越大。
注意：当播放器的宽度和高度都设为0时，播放器就看不到了。比如插入背景音乐时，就不需要看到播放器,所以可以设为0即可。

问：如何删除自动播放媒体文件？
答：分两种情况，第一：播放器的尺寸不为0时，直接在“设计”区单击此播放器，按“删除”按钮或者delete键，“提交”网页即可。
第二：播放器的尺寸为0时，就要点击“代码”区，按ctrl+ F 键，输入<EMBED 这几个字符（如下图）

找到<EMBED> </EMBED>这对标记所包含的代码，按delete键删除，再点击“设计”区，“提交”网页即可。比如代码为： <EMBED src=/data/userpic/20060614098838.wma width=0 height=0 type=audio/x-pn-realaudio-plugin autostart="true" controls="IMAGEWINDOW,ControlPanel,StatusBar" console="Clip1"></EMBED>


QQ在线功能

如何在编辑器上插入“QQ在线功能“ ？

第一步：现在就以底部区为例．首先打开网站底部区编辑器（如下图）

第二步：单击"插入QQ“按钮，弹出以下对话框，在“QQ号”一栏输入在网页中显示的QQ号码，然后单击小圆圈选一种样式，最后单击“确定”即可。

效果图如下：


其它按钮

显示隐藏指导方针：当表格边框为0的时候，表格是不可见的，这对我们进行网页设计就造成了不便，这个时候您可以单击此按钮。显示出边框为0的表格，方便我们进行编辑，虚线只是在设计的时候显示，不会在真正的网页上显示。如果要不显示虚线再点击一下这个按钮即可隐藏。

插入或者修改栏目框：单击此按钮，在弹出的对话框里（如下图）设置好相关属性，再点“确定”即可插入栏目框。

栏目框属性有两项：
对齐方式（栏目对齐 标题对齐） 栏目与标题的对齐方式都有三种，分别是：左对齐 居中对齐 右对齐，默认是左对齐。
颜色属性（边框颜色 背景颜色）在弹出的颜色对话框里，选择一种颜色即可。默认是黑色。

说明：栏目内容默认是黑色，标题字默认是蓝色。
插入栏目框后：如果想修改文字颜色，双击栏目内容或者标题，等字体周围出现八个小方格，并且光标在里面闪的时候，选中文字，再单击“字体颜色”按钮进行修改即可。
如果想修改文字内容，同样分别双击“栏目”和“标题”二字，等字体周围出现八个小方格，并且光标在里面闪的时候，输入新内容即可。
如果想修改对齐方式和颜色属性，就把鼠标移至边框线上，当鼠标指针变成方向箭（如图）时，单击一下鼠标，再点“插入或者修改栏目框”按钮，重新设置之后，按“确定”即可。

插入或者修改网页帧：先把光标放在需插入另一个新网页的位置，再单击此按钮，在弹出的对话框里（如下图）输入新网页的网址，设置好新网页的显示尺寸等属性，按“确定”即可。

网页帧的属性分别有：
网页地址（要插入新网页的网址，比如锐奇网，网址是www.51rich.net，因为此处已默认有http://了，所以无此重复输入这几个字符）
滚动条（有两个选项，即有和无，默认为有）
边框线（边框线默认为0，即无边框线。设为1就会在网页周围显示边框线，数值越大，边框线越粗）
上下边距（新插入的网页帧与本网页的上下两行内容之间的距离）
左右边距（新插入的网页帧与本网页的左右两边的内容之间的距离）
帧宽度（要插入的新网页的窗口宽度）
帧高度（要插入的新网页的窗口高度）

插入水平尺：把光标定位在需要插入横线的位置，然后单击按钮，即可插入一条横线。

插入或者修改字幕：单击此按钮，在弹出的对话框里（如下图）输入文字，选择一种表现方式，按“确定”即可。

插入文字特效，共有三个选项，分别是：
滚动（文字从右移至左不停地移动）
幻灯（文字从右移至左，然后停留在左边）
交替（文字从右移至左，再从左返回右，就这样不停地移动）

插入或者修改超链接：选中文字或者图片，然后单击此按钮，在弹出的对话框里（如下图）输入链接的网址即可。

属性描述：
链接类型（http: 链接一个网页 mailto:链接一个E-mail地址）
链接目标（相同框架 整页 新建窗口 父框架）
链接地址（要链接新网页的网址，比如锐奇网，网址是www.51rich.net，因为此处已默认有http://了，所以无此重复输入这几个字符）
书签链接（在网页里添加书签后，即可在此选择一个书签名称做链接。）

问：什么是书签？
答：书签是一种更为灵活、有趣的分类方式， 您可以简单地把一个书签理解为特殊的分类方式,或关键字。您可以按自己的想法在网页上加任意多个书签，用来标识一个链接和信息，方便网民查找。

下面说明一下如何使用书签：
例一：在同一个网页使用书签（以一般网站的“常见问答”栏目为例）
网站效果是：在网页的上方，会列出所有的问题，下方是每个问题的答案，网民点击每一个问题，都会跳转到正常答案的位置。详细的操作步骤就是:
首先第一步：添加书签。分别把光标放在每个答案的前面，再单击“标签管理”按钮，输入一个书签名称,比如第一个答案的书签名是#a1，第二个是#a2等等，然后按“确定”按钮。
第二步：设置书签链接。分别选中每个问题，再点“插入或者修改超链接”按钮，在“书签链接”的下拉菜单里，选择相应的书签名称，最后“确定”即可

例二：在不同的网页里使用书签。
网站效果是：要从A网页（网址是www.sohu.com）跳到B网页（网址是www.163.com）的某个位置，详细步骤如下：
首先第一步：就先在B网页里单击“标签管理”按钮，输入一个书签名称（比如a1）,然后按“确定”按钮。
第二步：再进入A网页里，选中文字或者图片，点“插入或者修改超链接”按钮，在“链接地址”栏，输入B网页的网址#标签名（即www.163.com#a1）。最后按“确定”即可。

标签管理：把光标放在需要做标签的位置，再单击“标签管理”按钮，在弹出的对话框里（如下图）输入标签名称，按“确定”即可。 如需删除标签，再次单击“标签管理”按钮，选中一个标签，按“删除”按钮即可。

图形热点链接：就是给一张图片的某个区域做链接，同一张图片，可做多个热点链接。
使用方法是：选中一张图片，再单击此按钮，弹出以下对话框（如下图）：

单击“新建”按钮，图片上会出现一个小方框（方框大小是可改变的，方法是：选中方框，周围会多出8个小方格，拖动小方格可将方框放大或者缩小。），将小方框移至需要做链接的位置，双击小方框，在弹出的对话框里（如下图），选择“链接目标”，再输入超链接的网址，按确定即可。重复以上步骤，即可给图片的另外一个区域做热点链接。

取消超链接或者标签：选中需取消超链接或者标签的文字或者图片，单击一下此按钮即可。

插入特殊字符：特殊字符一共分为6项，分别是：特殊、标点、数字、单位、数字、拼音。将光标放在需插入特殊字符的位置，然后点击此按钮，在弹出的对话框里（如下图），选中想要的特殊字符，即可插入，如果其中有几个不想要，在编辑区里删除即可。

插入表情图标：将光标放在需插入表格图标的位置，然后点击此按钮，在弹出的对话框里（如下图），选中想要的图标，即可插入。

插入或修改艺术字：将光标放在需插入表格图标的位置，然后点击此按钮，弹出以下对话框（如下图），在“文字”区输入内容，按确定即可。插入艺术字后如需修改，就选中艺术字，周围就会出现8个小方格后，拖动小方格，即可放大或者缩小字体。

插入当前日期：单击此按钮，即可插入当天日期。格式是：2006年6月15日 此日期是固定的，不会自动更新。

插入当前时间：单击此按钮，即可插入电脑的当前时间。格式是 15:07:25 此时间也是固定的，不会自动更新。


第四排工具栏：

各个按钮的作用如下：

插入段落：单击此按钮，输入文字，文字会以段落的形式显示。比如段间距会比行间距宽。

插入换行符：单击此按钮，可插入一个软回车，然后再输入文字，文字就会换行。

插入表格：第三排工具栏的“表格菜单”已介绍过

表格属性：第三排工具栏的“表格菜单”已介绍过

单元格属性:第三排工具栏的“表格菜单”已介绍过

拆分单元格：第三排工具栏的“表格菜单”已介绍过

表格行属性：第三排工具栏的“表格菜单”已介绍过

插入行：第三排工具栏的“表格菜单”已介绍过

插入行：第三排工具栏的“表格菜单”已介绍过

合并行：第三排工具栏的“表格菜单”已介绍过

拆分行：第三排工具栏的“表格菜单”已介绍过

删除行：第三排工具栏的“表格菜单”已介绍过

插入列：第三排工具栏的“表格菜单”已介绍过

插入列：第三排工具栏的“表格菜单”已介绍过

合并列：第三排工具栏的“表格菜单”已介绍过

拆分列：第三排工具栏的“表格菜单”已介绍过

删除列：第三排工具栏的“表格菜单”已介绍过

上移一层 ：将图片，放在对象（比如文字，图片或者表格）的上面一层。方法是：把光标放在对象的左边，插入一张图片，然后选中图片，把图片移动到对象上面即可。

下移一层 ：将图片，放在对象（比如文字，图片或者表格）的下面一层。效果类似于背景图。方法是：把光标放在对象的左边，插入一张图片，然后选中图片，把图片移动到对象下面即可。
注意：用“上移一层”和“下移一层”两个按钮移动图片时，都是只能向下或者向右移动到对象上。


第五排工具栏使用说明

第五排工具栏：

各个按钮的作用如下：

左对齐：选中一行、一段或者所有文字，单击此按钮，即可让文字往左边对齐。其它的“居中对齐 [image] 右对齐 [image] 两端对齐 [image] ”方法一样。

引用样式：单击此按钮，即可插入引用样式，效果如下图： （注：“以下是引用片段”这几个字的颜色可以修改的）

代码样式：单击此按钮，即可插入代码样式。效果如下图：（注：“以下是代码片段”这几个字的颜色可以修改的）

旧版的编辑器里，如果在“设计区”插入一段代码（例：如何做对联广告的代码），单击“保存”按钮后。如需修改代码，就重新再进入编辑器，但这时您会发现，原来插入的对联广告的代码不见了，还得再添加一遍才行，这样就给我们的编辑工作带来不便。针对这种现象，才研究出这个代码样式。以后如果您需要引用一段代码时，用"代码样式"就可以了。

全屏编辑：单击此按钮，即可将编辑器最大化。再单击一次，就会恢复原状。

使用帮助：查看编辑器的帮助文件。


引入模块界面

如何使用编辑器中的“ 引入模块界面”功能？

第一步：打开网页编辑器，单击“引入模块界面”按钮，如下图（有两处，随便点一个）：

第二步:在弹出的网页对话框里（如下图），单击左边的模块名称，可浏览模块的界面，右上角还有放大，缩小的功能，选中一个模块之后，最后单击“确定”按钮。

第三步：在模块里添加、修改内容。（如下图）可修改栏目名称，单击“显示隐藏辅助设计虚线”按钮，在空白的表格里输入内容，更换模块里的图片等操作，全部编辑好之后，点击“保存”按钮即可。对于一些不会排版网站的客户来说，用插入模块界面是个不错的选择！

单击网站预览，就可以看到效果！（如下图


自动引入各模板内容

如何引用编辑器中的：“自动引入各模板内容”功能？

打开任意一个编辑器，单击“自动引入各模板内容”按钮，选中要引入的内容，按提示操作即可。

其中引入站内搜索，会员登陆，引入网站语言与引入域名查询操作是一样的，都是选中之后，就可以直接使用了。

而其它的引入新闻、产品、商城商品、投票调查和图片轮换器，都是事先要在栏目里比如新闻系统管理、产品列表管理、商城管理等管理界面里，将内容编辑好之后，才可以到网页编辑器里引入的。网页编辑器里引入的这些内容，实际上是调用其它栏目里的！即与相应栏目里的内容是同步更新的。

例一：域名查询

第一步：选中引入域名查询（如下图）

第二步: 弹出下面的窗口，点击“域名查询”，这样就把域名查询的代码就插入到编辑器中，最后点击保存即可。

例二：引入新闻

1）第一步：在编辑器界面，单击“自动引入各模板内容”按钮，选中“引入新闻”如下图：

2）在弹出的对话框里(如下图)，设置好以下各项内容

在“引入”项，选中要引入的新闻栏目

“引入多少行”填写行数

“每行超出多少字则自动截取”比如填10,则新闻标题只显示10个字，超过以后，后面的字就不会显示出来了，而是用省略号来代替显示。

字体颜色：设置文字的颜色；

如果想在新闻后面显示日期，名称，粗体的话，在方框前面打上勾就可以了；

标题前的小图标样式：

系统：可选择软件自带的图标

网络：可使用其它个性化的图标。首先把小图标上传到后台“我的文档”里，然后复制它的网址，再粘贴到这里。

如果新闻标题前不显示小图标，则选“取消小图标”

3）单击“确定”后，编辑器里就会多一个php图标（如下图），最后点击“保存”即可。


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 1392k - 1.39MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • 自动生成上下文相关的帮助文件直接供程序员使用；
  • 支持导入任意的文件类型；
  • 自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 批量更换CHM目录各项的图标；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件。
  • 内嵌CHM反编译工具。
  • 用户可以保存和打开工程文件。

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 汇出行

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000
安装支持: 支持安装及卸载